August 7th, 2013 by spyware4me

I feel I should point out that v2.4.1, v2.4.2 and all following sites and solvers are compatible with v2.4.0 unless you use some feature (class/method/field) not present in the previous versions. In that case I would recommend checking the Multiclicker2 version at the beginning of all entry points using such new feature and stopping with the proper error when the version is not met.

Also don’t forget that Multiclicker2 2.4.0 and newer require at least Java 7 to run.

What’s new

  • Accounts are not saved anymore if their sites are missing.
  • Builder now behaves the same as sites when running a solver, especially when trying to report captcha validity.
  • Fixed click captcha region height limit and automatic width computation.
  • Fixed not hiding toolbar on startup when disabled in settings.
  • Fixed NullPointerException while choosing a solver for an account when two or more solvers of the same type are present.
  • Added getUserAgent() method to Page.